"This apk currently supports no device" error message


I tried to upload the latest version of my app and I’m getting this warning message:

This APK currently supports no device. In order to submit the app, this APK must support at least one device.

Please help me sort out this issue.

Hi Sara,

Welcome to our new community space, thanks for your question!

It looks like you accidentally uploaded your new APK file as a second APK file, instead of replacing the old one. To avoid this, make sure you click “Replace APK” on the old APK file instead of clicking “Add new APK”.


I’m having the same error for a brand new app I’m trying to upload.

Hi @Ronen ,

You are seeing this error because you have not targeted any devices.

Please see our guide to updating the supported devices:



When I try to edit the devices they are all grayed out.
I don’t think it’s the issue because I expect all devices to be selected after I upload the apk automatically without me having to select them manually.

I see what’s happening, looks like all devices in the list are old devices which don’t support Android 8 or Above? This came out 5 years ago and like 90 percent of devices in use today are above it.